An external serial modem does not return to autoanswer mode and incoming connections do not succeed after you turn off and then turn on the modem in Windows Server 2003 SP1 (906278)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003 with Service Pack 1 (SP 1), an external serial modem does not return to autoanswer mode after you turn off and then turn on the modem. Incoming connections do not succeed.

Note This problem does not occur after you turn off and then turn on the computer.

CAUSE

This problem occurs because of a race condition in the Windows Telephony API (TAPI). A race condition occurs when a resource is accessed by two or more threads at the same time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.252063,48831-Aug-200503:15x86SP1SP1QFE
Unimdmat.dll5.2.3790.252075,26431-Aug-200503:15x86SP1SP1QFE
Windows Server 2003, Enterprise Edition for Itanium-based Systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.2520158,72031-Aug-200504:40IA-64SP1SP1QFE
Unimdmat.dll5.2.3790.2520189,95231-Aug-200504:40IA-64SP1SP1QFE
Wrastapi.dll5.2.3790.252063,48831-Aug-200504:40x86SP1WOW
Wunimdmat.dll5.2.3790.252075,26431-Aug-200504:40x86SP1WOW
Windows Server 2003, Enterprise Edition for x64-based Systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.252085,50431-Aug-200504:40x64SP1SP1QFE
Unimdmat.dll5.2.3790.2520101,37631-Aug-200504:40x64SP1SP1QFE
Wrastapi.dll5.2.3790.252063,48831-Aug-200504:40x86SP1WOW
Wunimdmat.dll5.2.3790.252075,26431-Aug-200504:40x86SP1WOW

WORKAROUND

To work around this problem, restart the Routing and Remote Access service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbpubtypekc KB906278 kbAudITPRO