Error message when you run hardware inventory on SMS clients that are running Windows XP: "Unknown error encountered processing an instance of class win32_cdromdrive" (906277)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

You run hardware inventory on Microsoft Systems Management Server (SMS) clients that are running Microsoft Windows XP with Service Pack 2 (SP2) or Windows XP with Service Pack 1 (SP1). After you do this, an error message that is similar to the following may be logged in the hardware inventory agent client log file (Hinv32.log):
Unknown error encountered processing an instance of class win32_cdromdrive; 80041004 Collection ;(80041004) execute; queryfailed.
Notes
  • The Hinv32.log file is located in the %windir%\Ms\Sms\Logs folder.
  • You experience the symptoms only on client SMS computers that have a CD drive installed.

CAUSE

This problem may occur if the Restrict CD-ROM access to locally logged on users only security policy is enabled on the client computers.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Licdll.dll5.1.2600.1746398,84814-Sep-200502:11x86SP1SP1QFE
Winlogon.exe5.1.2600.1746483,32814-Sep-200502:01x86SP1SP1QFE
Licdll.dll5.1.2600.2759423,93614-Sep-200502:01x86SP2SP2QFE
Winlogon.exe5.1.2600.2759502,78414-Sep-200501:56x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbtshoot kbfix kbbug kbpubtypekc KB906277 kbAudITPRO