Incoming queue backlogs become larger than you expect if you use performance counters on a Microsoft Operations Manager 2005-based server (904944)



The information in this article applies to:

  • Microsoft Operations Manager 2005
  • Microsoft Operations Manager 2005 SP1

SYMPTOMS

If you use performance counters on a Microsoft Operations Manager 2005-based server, incoming queue backlogs become larger than you expect. When this symptom occurs, the following event is recorded on the MOM Server 2005-based computer: Event Type: Error
Event Source: Microsoft Operations Manager
Event Category: MOM Server
Event ID: 21268
Date:
Time:
User: NT AUTHORITY\NETWORK SERVICE
Computer:
Description:
The Server incoming queue data submission has been blocked. This may indicate that queue does not have sufficient space or is unavailable to accept data. Management Group: groupname

CAUSE

This problem occurs if the following conditions are true:
  • You create MOM performance counters.
  • The MOM performance counters use the InstanceName property.
For example, the Exchange 2003 - Collect Message Tracking Log Statistics script from the Exchange 2003 Management Pack creates counters that use the InstanceName property. The Exchange 2003 - Collect Message Tracking Log Statistics script reads the Exchange MTA log. The Exchange 2003 - Collect Message Tracking Log Statistics script creates counters that are based on e-mail usage information from the Exchange MTA log. In this example, the InstanceName property is the user's e-mail address.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Operations Manager 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires MOM 2005.

Restart requirement

You do not have to restart the computer.

Note Data insertion may be delayed while the hotfix is being applied.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
    Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Aug-2005  19:14                    137,728  Momrunscript.exe  

WORKAROUND

To work around this problem, do not use the InstanceName property when you use a script to create MOM performance counters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/25/2006
Keywords:kbfix kbQFE kbExpertiseInter kbMOMpre2005SP1fix kbOpman2005spfix KB904944 kbAudITPRO