You receive a "This folder already contains a file named '<filename>'" message when you copy an NTFS encrypted file to a new location on a Windows XP Service Pack 2-based computer (904829)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

SYMPTOMS

Consider the following scenario:
  • You have installed file security products on a Microsoft Windows XP Service Pack 2 (SP2)-based computer.
  • You are using drives that are formatted to use the NTFS file system.
  • You copy an NTFS encrypted file to a new location on the computer.
In this scenario, you receive the following message:This folder already contains a file named 'filename'.

Would you like to replace the existing file

filesize
modified date and time

with this one?

filesize
modified date and timeYou receive this message even though you copied the encrypted file to a folder that does not already contain the encrypted file.

CAUSE

This problem occurs because some file security products disable the NTFS encryption function by using a file system filter driver. The filter driver disables the NTFS encryption function by returning an error on data encryption requests. The Lsasrv.dll module does not correctly handle this error.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   27-Jul-2005  02:33  5.1.2600.1721     666,624  Lsasrv.dll       
   27-Jul-2005  02:24  5.1.2600.2727     726,016  Lsasrv.dll       
   26-Jul-2005  23:49  5.1.2600.2727      30,720  Arpidfix.exe 
   25-Feb-2005  03:35  6.1.22.4          371,936  Updspapi.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB904829 kbAudITPRO