A Windows Server 2003-based computer stops responding, and you receive a "Stop 0x000000F4" error message (904779)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition

SYMPTOMS

Consider the following scenario:
  • You are using one of the following computer configurations:
    • The original release version of Microsoft Windows Server 2003 with hotfix 842642 applied
    • Windows Server 2003 with Service Pack 1 (SP1) . The following registry subkey is enabled:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\GRE_Initialize\SupportLinkedFontConTextOut

      Additionally, the value of the SupportLinkedFontConTextOut entry is 1.
  • You are running the Japanese version of Windows Server 2003. Windows Server 2003 is configured to use Japanese for non-Unicode programs.
  • At the command prompt, you run a command that contains kanji characters. You then change the Command Prompt window to full-screen mode.
In this scenario, the Windows Server 2003-based computer stops responding. Additionally, you receive error messages that are similar to the following:
Stop 0x000000F4 (parameter1, parameter2, parameter3, parameter4)
CRITICAL_OBJECT_TERMINATION

CAUSE

The problem occurs because Windows Server 2003 incorrectly processes the size of the buffer that stores character information for full-screen mode.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are two hotfixes for this problem. If you want to install the hotfix for the original version of Windows Server 2003, no prerequisites are required. If you want to install the hotfix for Windows Server 2003 with SP1, install Windows Server 2003 SP1 before you install that hotfix.

Note x64-based versions of Windows Server 2003 include Windows Server 2003 SP1.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 842642.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Win32k.sys5.2.3790.25605,544,44831-Oct-200523:57IA-64SP1
Winsrv.dll5.2.3790.2560814,59231-Oct-200523:57IA-64SP1
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.4354,965,88831-Oct-200523:57IA-64
Winsrv.dll5.2.3790.435766,97631-Oct-200523:57IA-64
Windows Server 2003 with SP1
File nameFile versionFile sizeDateTimePlatformSP requirement
Win32k.sys5.2.3790.25601,848,32001-Nov-200501:57x86SP1
Winsrv.dll5.2.3790.2560297,47201-Nov-200504:08x86SP1
Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.4351,818,11201-Nov-200501:06x86
Winsrv.dll5.2.3790.435292,86401-Nov-200503:58x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Win32k.sys5.2.3790.25604,517,37631-Oct-200523:57x64SP1
Winsrv.dll5.2.3790.2560509,44031-Oct-200523:57x64SP1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbWinServ2003preSP1fix kbpubtypekc KB904779 kbAudITPRO