The Set Affinity dialog box in Windows Task Manager does not show all the available CPUs on a computer that is running a Dutch, French, Russian, or Swedish version of Windows Server 2003 (904772)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

On a computer that is running a Dutch, French, Russian, or Swedish version of Microsoft Windows Server 2003, the Set Affinity dialog box in Windows Task Manager does not show all the available CPUs.

CAUSE

This problem occurs because the Set Affinity dialog box does not dynamically resize in width to fit the varying lengths of the term "CPU" in various languages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit versions
   Date         Time   Version          Size  File name
   ------------------------------------------------------
   06-Aug-2005  02:08  5.2.3790.383  127,488  Taskmgr.exe
Windows Server 2003, 32-bit versions with Service Pack 1
   Date         Time   Version           Size  File name
   -------------------------------------------------------
   06-Aug-2005  02:52  5.2.3790.2503  168,960  Taskmgr.exe
Windows Server 2003, 64-bit Itanium-based versions
   Date         Time   Version          Size  File name     Platform
   -----------------------------------------------------------------
   05-Aug-2005  13:49  5.2.3790.383  318,976  Taskmgr.exe   IA-64
   05-Aug-2005  13:49  5.2.3790.383  127,488  Wtaskmgr.exe  x86
Windows Server 2003, 64-bit Itanium-based versions with Service Pack 1
   Date         Time   Version           Size  File name     Platform
   ------------------------------------------------------------------
   05-Aug-2005  13:49  5.2.3790.2503  438,272  Taskmgr.exe   IA-64
   05-Aug-2005  13:49  5.2.3790.2503  168,960  Wtaskmgr.exe  x86
Windows Server 2003, 64-bit x64-based versions
   Date         Time   Version           Size  File name     Platform
   ------------------------------------------------------------------
   05-Aug-2005  13:49  5.2.3790.2503  237,056  Taskmgr.exe   x64
   05-Aug-2005  13:49  5.2.3790.2503  168,960  Wtaskmgr.exe  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbpubtypekc KB904772 kbAudITPRO