FIX: You may receive a message box when you try to install Windows Messenger 5.1 in unattended mode on Windows Server 2003 SP1 or on Windows XP SP2 (904023)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows Messenger 5.1

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003 Service Pack 1 (SP1) or Microsoft Windows XP Service Pack 2 (SP2), you may receive a message box when you try to install Microsoft Windows Messenger 5.1 by using the /Q switch. The /Q switch runs the Setup program in unattended mode. This mode is also known as a quiet install.

This problem occurs when a dependent application such as Microsoft Outlook Express is running. The message box prompts you to close the dependent application before you continue the installation process. This behavior is not consistent with unattended mode.

CAUSE

This problem occurs when Microsoft Windows Installer uses the RemoveExistingProducts action. The RemoveExistingProducts action calls the uninstall routine. However, this action does not pass the ClientUILevel property to the uninstall process. Therefore, the Setup program does not continue in unattended mode, and you receive the message box that is mentioned in the "Symptoms" section.

RESOLUTION

Hotfix information

Windows Server 2003 SP1

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesThere are no prerequisites to install this hotfix.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   31-Aug-2005  00:47  3.1.4000.2520  78,848  Msiexec.exe
Windows Server 2003, 64-bit version
   Date         Time   Version        Size     File name    Platform
   -----------------------------------------------------------------
   31-Aug-2005  03:39  3.1.4000.2520  165,376  Msiexec.exe  x64

Windows XP SP2

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesThere are no prerequisites to install this hotfix.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, IA-64 bit version
   Date         Time   Version        Size     File name    Platform
   -----------------------------------------------------------------
   31-Aug-2005  03:39  3.1.4000.2520  229,376  Msiexec.exe  IA-64
Windows XP, 32-bit version
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   30-Aug-2005  23:53  3.0.3790.2750  77,312  Msiexec.exe

WORKAROUND

To work around this problem, follow these steps:
  1. Remove any earlier version of Microsoft Windows Messenger from the computer.
  2. Run the Setup program for Windows Messenger 5.1 again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbtshoot kbfix kbbug kbHotfixServer kbQFE KB904023 kbAudDeveloper kbAudITPRO