The Microsoft Exchange Information Store service may crash when it processes a rule that has a NULL value for the Action setting (903924)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

When a Microsoft Outlook client computer receives an e-mail message, the e-mail message triggers Microsoft Exchange 2000 Server to process the rules that have been configured for that mailbox. When the Microsoft Exchange Information Store service processes a rule that has a NULL value for the Action setting, the Information Store service may crash.

CAUSE

This problem occurs because the existing code cannot logically determine whether an action is NULL. You should not use a NULL value for the Action setting in a rule.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup.

For more information about this software update, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.0.6617.882,342,91209-Sep-200522:29x86
Store.exe6.0.6617.884,714,49609-Sep-200523:20x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbexchSTORE kbQFE kbfix kbExchange2000preSP4fix kbbug kbpubtypekc KB903924 kbAudITPRO