You experience a long delay when you try to view the DACL or the SACL security information for an object after you install Windows Server 2003 Service Pack 1 (903662)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

After you install Microsoft Windows Server 2003 Service Pack 1 (SP1), when you click the Security tab in the Properties dialog box of an object to try to view the users and groups in the discretionary access control list (DACL) or the system access control list (SACL), you experience a long delay.

This problem occurs in particular for lists that have many groups in them. When you open the DACL or the SACL, you may see many calls to the DRSCrackNames remote procedure call (RPC) function in a trace of the activity on the network. This RPC function calls target domain controllers on the primary domain and on other trusted domains.

CAUSE

This problem occurs because the ability to display the common name for groups was added in hotfix 818739. This behavior adds several round trips to the domain controllers where these groups are hosted and adds a noticeable delay when the lists are long.

Note Hotfix 818739 is included in Windows Server 2003 Service Pack 1. For more information about hotfix 818739, click the following article number to view the article in the Microsoft Knowledge Base:

818739 Groups are displayed by using their SAM account names instead of their display names

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Note Windows Server 2003 Service Pack 1 is included in x64-based versions of Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix unless the Aclui.dll file is being used by a management component or by the Properties dialog box of a GPO.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aclui.dll5.2.3790.2622180,73620-Jan-200604:01x64SP1Not Applicable
Waclui.dll5.2.3790.2622120,32020-Jan-200604:01x86SP1WOW
Windows Server 2003, 64-bit Itanium-based versions with SP1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aclui.dll5.2.3790.2622314,36820-Jan-200604:01IA-64SP1Not Applicable
Waclui.dll5.2.3790.2622120,32020-Jan-200604:01x86SP1WOW
Windows Server 2003, 64-bit x64-based versions with SP1
File nameFile versionFile sizeDateTimePlatform
Aclui.dll5.2.3790.2622120,32020-Jan-200603:46x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Hotfix 903662 introduces the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ACLUI\TranslateName registry subkey.
NameTypeData
TranslateNameREG_DWORD0 or 1

The TranslateName registry subkey switches the display of group names between the pre-Windows Server 2003 SP1 behavior and the post-Windows Server 2003 SP1 behavior. By default, hotfix 903662 sets the value of the TranslateName registry subkey to 0, to use the pre-Windows Server 2003 SP1 behavior. To use the post-Windows Server 2003 SP1 behavior, change the value to 1.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB903662 kbAudITPRO