You receive a "Document Exchange requires SQL Server 2000 or MSDE with Service Pack 2 or higher" error message when you try to install Microsoft CRM Integration for Great Plains on a computer that is running SQL Server 2000 with Service Pack 4 (903278)



The information in this article applies to:

  • Microsoft Business Solutions CRM Integration for Great Plains, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

Notice

SYMPTOMS

When you try to install Microsoft Business Solutions CRM Integration for Great Plains on a computer that is running Microsoft SQL Server 2000 with Service Pack 4, the Document Exchange installation fails. When the installation fails, you receive the following error message:
Document Exchange requires SQL Server 2000 or MSDE with Service Pack 2 or higher. Please install one of these products before attempting to install Document Exchange.

CAUSE

This error message occurs because the Document Exchange Setup program performs a version check against the SQLdmo.dll file. The Document Exchange Setup program checks for file version 8.00.534. However, the file version is 8.00.2026 after SQL Server 2000 SP4 has been installed. Therefore, the version check fails if SQL Server 2000 SP 4 or a later service pack has been installed. This is a known problem.

RESOLUTION

This error message can be resolved in two ways, depending on which products are already installed.

Check to see whether one of the following products is already installed on the Microsoft CRM Integration server:
  • Microsoft SQL Server 2000 SP4 or a later service pack
  • Microsoft SQL Server Desktop Engine (also known as MSDE 2000) SP4 or a later service pack


If none of these products is already installed on the Microsoft CRM Integration server, follow these steps on the Microsoft CRM Integration server:
  1. Install Microsoft SQL Server 2000.
  2. Install Microsoft SQL Server 2000 Service Pack 3.
  3. Install Microsoft CRM Integration for Great Plains.
  4. Install Microsoft SQL Server 2000 Service Pack 4 or a later service pack.
If any one of the products that are listed near the start of the "Resolution" section is already installed on the Microsoft CRM Integration server, follow these steps on the Microsoft CRM Integration server:
  1. Download SQL Server 2000 SP3a. To do this, visit the following Microsoft Web site:
  2. Run Sql2ksp3.exe, and then extract the files into the Sql2ksp3 folder.
  3. Close all open programs on the Microsoft CRM Integration server, and then locate the following folder:

    %DRIVE%:\Program Files\Microsoft SQL Server\80\Tools\Binn

  4. Rename the existing Sqldmo.dll file to Sqlcmo.dll.sp4.

    Note You should not have to stop the SQL Server services or to restart the server in order to rename this file.
  5. Copy the Sqldmo.dll file from the Sql2ksp3\X86\Binn folder, and then paste the copied file into the following folder:

    %DRIVE%:\Program Files\Microsoft SQL Server\80\Tools\Binn

  6. Install Microsoft Business Solutions CRM Integration for Great Plains.
  7. Locate the Sqldmo.dll file in the following folder:

    %DRIVE%:\Program Files\Microsoft SQL Server\80\Tools\Binn

  8. Rename the Sqldmo.dll file to Sqldmo.dll.sp3.
  9. Rename the Sqldmo.dll.sp4 file to Sqldmo.dll.
Note Microsoft Business Solutions CRM Integration for Great Plains version 1.0 and version 1.2 are not compatible with Microsoft SQL Server 2005.

MORE INFORMATION

Steps to reproduce the problem

  1. Install Microsoft SQL Server 2000.
  2. Install Microsoft SQL Server 2000 Service Pack 4.
  3. Install Microsoft CRM Integration for Great Plains.
You receive the error message that is mentioned in the "Symptoms" section.

Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbMBSMigrate kberrmsg kbprb KB903278 kbAudEndUser