FIX: An Office 2003 application stops responding for 10 to 15 seconds when you save a document that contains paths to resources that do not exist on the network on a computer that is running Windows Server 2003 (903087)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When you save a document in Microsoft Office 2003 on a computer that is running Microsoft Windows Server 2003, the Office 2003 application stops responding for 10 to 15 seconds. This behavior occurs when the saved document contains hyperlinks or Universal Naming Convention (UNC) paths to resources that do not exist on the network.

Note This problem does not affect performance when you access resources over the network, such as file copy operations.

CAUSE

This problem occurs because name resolution fails and time-outs occur.

RESOLUTION

Hotfix rollup package information

This problem is fixed in the Microsoft COM+ 1.5 hotfix rollup package 7. For more information about the rollup package, click the following article number to view the article in the Microsoft Knowledge Base:

910730 Availability of Windows Server 2003 Post-Service Pack 1 COM+ 1.5 Hotfix Rollup Package 7

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25721,247,23217-Nov-200503:20
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.4451,193,98417-Nov-200503:09
Windows Server 2003, Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25723,999,74416-Nov-200518:45IA-64
Wole32.dll5.2.3790.25721,247,23216-Nov-200518:45
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.4453,582,97616-Nov-200518:45IA-64
Wole32.dll5.2.3790.4451,193,98416-Nov-200518:45
Windows Server 2003, x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25722,546,68816-Nov-200518:45x64
Wole32.dll5.2.3790.25721,247,23216-Nov-200518:45x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If you monitor network traffic when you try to save the Office 2003 file, you can see name resolution requests to the server resources that are used in the hyperlinks and the UNC paths that are in the document. You can also see that these names cannot be resolved successfully.

By attaching Logger.exe from the Debugging Tools for Windows to the Office 2003 application, you can see a delay in the GetLongPathNameW function calls.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

260943 Slow performance accessing files may slow Office programs

For more information about the Debugging Tools for Windows, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:12/2/2005
Keywords:kbHotfixRollup kbQFE kbBug kbfix KB903087 kbAudDeveloper kbAudITPRO