You may be prompted to restart the computer when you upgrade a computer that is running an x64-based version of Windows Server 2003 or of Windows XP from a uniprocessor to a multiprocessor configuration (903006)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you add or change logical or physical processors to upgrade a computer that is running an x64-based version of Microsoft Windows Server 2003 or of Microsoft Windows XP from a uniprocessor to a multiprocessor configuration, you experience the following symptoms:
  • When you start the computer, you may receive a message that states that new hardware is found, and you may be prompted to restart the computer.
  • Although the basic input/output system (BIOS) and the Device Manager tool both show the correct number of processors, Microsoft WinDbg Debugger (Windbg.exe) and the Task Manager tool both indicate only one processor.
If you restart the computer, you do not receive the message again, and WinDbg Debugger and Task Manager both indicate the correct processor configuration.

If you remove or change logical or physical processors to change the computer from a multiprocessor to a uniprocessor configuration and then start the computer, you may be prompted to restart the computer.

CAUSE

This behavior occurs because support for the new processor configuration must be enabled after the Plug and Play manager detects the processor change. For support for the new processor configuration to be enabled, the computer must be restarted.

WORKAROUND

To work around this behavior, restart the computer after you change the processor configuration and start the computer. When you take this action, full support for the new processor configuration is enabled.

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:7/14/2005
Keywords:kbtshoot kberrmsg KB903006 kbAudEndUser