You cannot use the Computer Management feature on a Windows XP SP2-based computer to access Logical Disk Manager on a Windows Server 2003-based computer (902430)



The information in this article applies to:

  • Microsoft Windows XP Professional SP2

SYMPTOMS

Consider the following scenario: You use the Computer Management feature on a Microsoft Windows XP Service Pack 2 (SP2)-based computer to connect to a Microsoft Windows Server 2003-based computer. Then, you click Disk Management to access Logical Disk Manager on the Windows Server 2003-based computer. In this scenario, you may receive the following error message:
You do not have access rights to Logical Disk Manager on computer
You receive this error message even though you used valid administrative credentials to connect to the Windows Server 2003-based computer.

CAUSE

This issue occurs because of changes that were made in Component Object Model (COM) permissions and in DCOM permissions in Windows XP SP2.

For more information about changes to functionality in Network Protection Technologies in Windows XP SP2, visit the following Microsoft Web site:

RESOLUTION

To resolve this issue, follow these steps on the Windows XP-based computer:
  1. Verify that the following conditions are true:
    • Your Firewall will allow the Dmremote.exe process.
    • TCP port 135 is open.
    How you perform this verification process depends on your particular firewall. For example, to do this in Windows Firewall, follow these steps:
    1. Click Start, click Run, type firewall.cpl, and then click OK.
    2. Click the Exceptions tab.
    3. Click Add Program, and then type C:\WINDOWS\system32\dmremote.exe.
    4. Click OK.
    5. Click Add Port.
    6. In the Name box, type TCP port 135.
    7. In the Port number box, type 135, click TCP, and then click OK two times.
  2. Click Start, click Run, type dcomcnfg, and then click OK.
  3. In the Component Services window, expand Component Services, and then click Computers.
  4. Right-click My Computer, and then click Properties.
  5. Click the COM Security tab.
  6. In the Access Permissions area, click Edit Limits.
  7. Click ANONYMOUS LOGON. In the bottom pane, click to select the Remote Access check box in the Allow column, and then click OK.
  8. In the Launch and Activation Permissions area, click Edit Limits.
  9. Click Everyone, and then in the Allow column, click to select the Remote Launch and Remote Activation check boxes.
  10. Click OK two times, and then restart the computer.

Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbtshoot kberrmsg KB902430 kbAudITPRO