A Web form does not submit a user name and a password to a Web server in Internet Explorer 6 (902409)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario:
  • The Web server uses the HTTP Negotiate Authorization header to authenticate clients on a Web site.
  • You use Microsoft Internet Explorer 6 to access this Web site from a client computer.
  • You are prompted to enter the user name and the password.
  • After you enter the user name and the password and then click OK, you receive a Forms Based Authentication HTML page that includes a Web form. This Web form contains a user name field and a password field. The Web page also includes a message that states that the Web server denies NTLM authentication.
  • You enter the user name and the password in the Web form, and then submit the Web form.
In this scenario, the Web form does not submit the user name and the password to the Web server.

CAUSE

This problem occurs because the Wininet.dll file prevents the data from being sent when the client uses NTLM authentication, and the Web server expects a Simple and Protected GSSAPI Negotiation Mechanism (SPNEGO) response.

When you submit the user name and password for the first time, the Wininet.dll file on the client computer adds an NTLM response to the Negotiate Authorization header. If the Web server expects an SPNEGO response, the Web server may send a response that is not "401 Access Denied." Because the response is not "401 Access Denied," Wininet.dll incorrectly assumes that the authentication was successful. When Wininet.dll assumes that a successful authentication has occured, Wininet.dll removes the authentication data that it saved and does not resend the data.

RESOLUTION

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:02  6.0.2900.2754  660,480  Wininet.dll         SP2
   07-Sep-2005  00:09  5.1.2600.2754   30,720  Arpidfix.exe        SP2
   06-Sep-2005  10:36  6.0.2800.1521  585,728  Wininet.dll         SP1

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:29  6.0.3790.404   628,224  Wininet.dll
   07-Sep-2005  02:50  6.0.3790.2524  663,040  Wininet.dll         SP1
   07-Sep-2005  00:29  5.2.3790.2524   32,256  Arpidfix.exe        SP1

Hotfix installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply this hotfix, enable the hotfix by adding two registry entries in the registry. To add these registry entries, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. To activate this hotfix on a per-user basis, click one of the following registry subkeys:
    • HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_CURRENT_USER\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Note You only have to add the registry entries to one of these registry subkeys.


    To activate this hotfix on a per-machine basis, click one of the following registry subkeys:
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_LOCAL_MACHINE\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Note You only have to add the registry entries to one of these registry subkeys.

  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409 , and then press ENTER.
  5. Click FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. Type Iexplore.exe to name the new DWORD value, and then press ENTER.
  8. Double-click Iexplore.exe, type 1 in the Value data box, and then click OK to enable the hotfix.

    Note To disable the hotfix, type 0 in the Value data box.
  9. To add the Explorer.exe registry entry, repeat steps 3 through 5. In step 4, type Explorer.exe instead of Iexplore.exe.
  10. Quit Registry Editor.

WORKAROUND

To work around this problem, configure the Web server to support NTLM authentication. To obtain more information about how to configure the Web server to perform NTLM authentication, contact the vendor of the Web server. For information about how to contact the vendor of the Web server, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbWinServ2003SP1fix kbWinServ2003preSP1fix kbWinXPsp2fix kbWinXPpreSP2fix kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug kbHotfixServer kbpubtypekc KB902409 kbAudITPRO