FIX: Error messages when you use a Windows Management Instrumentation (WMI) query to register WMI events on a computer that is running Windows Server 2003 or Windows XP: "0x80041032" and "0x80041003" (902346)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You use a Microsoft Windows Management Instrumentation (WMI) query that contains the LIKE operator to register WMI events on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP. When you do this, the event registration fails. Additionally, you may receive the following error messages:

Error message 1
Number: 0x80041032
Facility: WMI
Description: Call cancelled
Note In this error message, the word "cancelled" is a misspelling for the word "canceled."

Error message 2
Number: 0x80041003
Facility: WMI
Description: Access denied

CAUSE

This problem occurs because the Windows NT Event Log provider cannot parse a WMI Query Language (WQL) event registration query that contains the LIKE operator.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.Restart requirementYou do not have to restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466235,52016-Jun-200515:53x86
Windows Server 2003 SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466708,09616-Jun-200501:14IA-64
Windows Server 2003 SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466359,42416-Jun-200501:14x64

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed on the computer.Restart requirementYou do not have to restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466359,42416-Jun-200501:14x64
Windows XP SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.1.2600.2699212,48016-Jun-200515:18x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB902346 kbAudITPRO