You receive an "Installation aborted. Unable to find correct path to install files" error message when you try to install a hotfix for Host Integration Server 2000 or for Host Integration Server 2000 SP1 (902293)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1


SYMPTOMS

When you try to install a hotfix for Microsoft Host Integration Server 2000 hotfix or for Host Integration Server 2000 Service Pack 1 (SP1), you receive the following error message:
Installation Aborted. Unable to find correct path to install files.

CAUSE

This problem may occur if one of the following conditions is true:
  • You try to install the hotfix on a computer that does not have Host Integration Server installed.
  • The Host Integration Server installation is either incomplete or corrupted.
Host Integration Server 2000 and Host Integration Server 2000 SP1 hotfixes use the SMS Installer to install the hotfix files. The SMS Installer searches for one of the following values:
  • The %SNAROOT% environment variable

    Note By default, the %SNAROOT% environment variable is set to C:\Program Files\Host Integration Server\system.
  • The CommonFiles value in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Sna Server\CurrentVersion\Setup subkey
  • The RootDir value in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Sna Server\CurrentVersion\Setup subkey
The %SNAROOT% environment variable exists on all servers. At least one of the registry values exists on all server/client installations. If the hotfix installer cannot find one of these values, you receive the error message that is mentioned in the "Symptoms" section.

Note Host Integration Server 2000 SP2 and later versions use Windows Installer to install the hotfix files.

RESOLUTION

To resolve this problem, make sure that you install the hotfix on a computer on which Host Integration Server is installed. If Host Integration Server is installed on the computer, make sure that you log on by using a user account that has permissions to read the registry keys that are mentioned in the "Cause" section.

If the Host Integration Server computer is missing the %SNAROOT% environment variable and the registry values in the "Cause" section, your installation of Host Integration Server may either be incomplete or corrupted. In this scenario, we recommend that you restore the registry from a known good backup. Then try to install the hotfix again.

Modification Type:MinorLast Reviewed:7/25/2005
Keywords:kbtshoot kbClient kbServer kberrmsg kbUpgrade kbsetup KB902293 kbAudITPRO