The FTP client may echo account information back to the screen in Windows Server 2003 and Windows XP (902149)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

Consider the following scenario:
  • You are using a computer that is running Microsoft Windows Server 2003 Service Pack 1 (SP1), Microsoft Windows XP SP1, or Microsoft Windows XP Service Pack 2 (SP2).
  • You are using the FTP command to connect to an FTP site and to provide account credentials.
In this scenario, the FTP client may echo account information back to the screen. This problem does not occur when you use the FTP command on a Microsoft Windows 2000-based computer.

CAUSE

This problem occurs because of a change that has to be incorporated in the FTP clients. This change was first made in the FTP client that was designed for Windows 2000. The change that was made in the Windows 2000-based FTP client is the standard for most FTP clients.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart the computer.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions
Date         Time   Version            Size    File name Service Pack
----------------------------------------------------------------------
21-Jul-2005  00:21  5.2.3790.374       45,056  Ftp.exe          
21-Jul-2005  00:39  5.2.3790.2492      46,080  Ftp.exe   SP1       
 
Windows Server 2003, x64-based versions
Date         Time   Version            Size    File name
--------------------------------------------------------------
20-Jul-2005  15:53  5.2.3790.2492      65,024  Ftp.exe          
   

Windows Server 2003, Itanium-based versions
Date         Time   Version            Size    File name Service Pack
----------------------------------------------------------------------
20-Jul-2005  15:53  5.2.3790.374      107,008  Ftp.exe          
20-Jul-2005  15:53  5.2.3790.2492     116,736  Ftp.exe    SP1 
   

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart the computer.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, x64-based versions
Date         Time   Version            Size    File name
--------------------------------------------------------------
20-Jul-2005  15:53  5.2.3790.2492      65,024  Ftp.exe          

Windows XP, x86-based versions
Date         Time   Version            Size    File name  Service Pack
----------------------------------------------------------------------
21-Jul-2005  00:15  5.1.2600.2723      42,496  Ftp.exe    SP1
21-Jul-2005  00:15  5.1.2600.2723      42,496  Ftp.exe    SP2      
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPsp1fix kbWinServ2003SP1fix kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB902149 kbAudITPRO kbAudEndUser