Some custom printer properties may be unavailable in a 64-bit version of Windows Server 2003 or Windows XP (902066)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

When you connect a printer to a computer that is running a 64-bit version of Microsoft Windows Server 2003 or Microsoft Windows XP, some custom printer properties may be unavailable. Because of this problem, you may experience one or more of the following symptoms:
  • Some programs cannot optimize the printer and use all the printer's capabilities.
  • You cannot print.
  • Print quality is poor.
  • You receive an "insufficient memory" error message.
For example, you may experience these problems when you try to print to an HP DesignJet printer from Autodesk's AutoCAD.

CAUSE

Some custom printer queries are not supported in the 64-bit versions of Windows Server 2003 and Windows XP. Programs such as AutoCAD use custom printer queries to print large format complex drawings.

The problem occurs because the pOutput <> pointer that is received by the DrvDeviceCapabilities function in the printer driver is always NULL. The pointer is NULL regardless of whether the program has assigned a valid pointer when the program calls the DeviceCapabilities function. Therefore, the program cannot obtain the information from the printer that enables the program to optimize the Graphics Device Interface (GDI).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 or Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x64-based versions or Windows XP Professional x64 Edition

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   13-Jun-2005  18:28  5.2.3790.2463      38,400  Splwow64.exe   x64

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   13-Jun-2005  18:28  5.2.3790.2463      72,192  Splwow64.exe   IA-64


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates



The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbBug kbWinXPpreSP3fix kberrmsg kbQFE kbHotfixServer KB902066 kbAudEndUser