You receive a "Could not connect EDI Subsystem (StartDatabase returned -2) to Database" error message, and the BizTalk Base EDI service does not start in BizTalk Server 2004 (901267)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition

SYMPTOMS

In Microsoft BizTalk Server 2004, when you try to start the BizTalk Base Electronic Data Interchange (EDI) service, you receive an error message that is similar to the following in the Application log:
Could not connect EDI Subsystem (StartDatabase returned -2) to Database
Additionally, the BizTalk Base EDI service does not start.

CAUSE

This problem occurs if the following conditions are true:
  • The BizTalk Base EDI database is on a remote computer that is running Microsoft SQL Server 2000.
  • The SQL Server client tools are not installed on the computer that is running the BizTalk Base EDI service.

RESOLUTION

To resolve this problem, install the SQL Server client tools on the computer that is running the BizTalk Base EDI service. After you install the SQL Server client tools, you can successfully start the BizTalk Base EDI service.

Note The SQL Server client tools are located on the SQL Server 2000 installation CD.

MORE INFORMATION

For more information about BizTalk Server 2004 deployment, visit the following Microsoft Developer Network (MSDN) Web site:

Modification Type:MajorLast Reviewed:7/20/2005
Keywords:kbService kbstartup kbinfo kbtshoot kbprb KB901267 kbAudDeveloper kbAudITPRO