SYMPTOMS
When you map a large document in Microsoft BizTalk Server 2004, you may experience all the following symptoms:
- Message processing unexpectedly stops.
- The Microsoft Distributed Transaction Coordinator (MSDTC) service stops committing transactions.
- The following event is logged in the application event log on the computer that is running BizTalk Server 2004: Event Type: Error
Event Source: BizTalk Server 2004
Event Category: BizTalk Server 2004
Event ID: 7683
Date: date
Time: time
User: N/A
Computer: computername
Description:
Tracking Interceptor: Get Context property failed, error code 8007000e.
Note When this problem occurs, Microsoft SQL Server 2000 may also generate error messages to indicate that SQL Server is out of resources.
CAUSE
This problem may occur if the document goes through a map into a receive pipeline that uses a Disassembler component. BizTalk Server 2004 runs the pipeline disassembly stage after the document transformation stage. BizTalk Server 2004 can track the Pipeline context in managed code or in unmanaged code. This problem occurs when the Pipeline context is tracked in unmanaged code.
This problem occurs because BizTalk Server 2004 does not correctly release unmanaged memory from the default heap. Therefore, BizTalk Server 2004 runs out of memory. The error code 8007000e that is mentioned the Symptoms section corresponds to the following error message:
Not enough storage is available to complete
this operation.
This error message indicates an out of memory condition.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2004 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
You must have BizTalk Server 2004 Service Pack 1 (SP1) installed to apply this hotfix.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
888751
How to obtain the latest BizTalk Server 2004 service pack
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
-----------------------------------------------------------------------------------------
09-Jun-2005 22:39 3.0.6131.0 1,041,408 Btsmsgcore.dll
09-Jun-2005 22:12 3.0.6131.0 12,288 Microsoft.biztalk.epmtransform.dll
09-Jun-2005 22:10 3.0.6131.0 53,248 Microsoft.biztalk.messaging.dll
09-Jun-2005 22:01 3.0.6131.0 45,056 Microsoft.biztalk.streaming.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.