A Terminal Services client computer may make beep sounds after you connect to a Windows Server 2003 Service Pack 1-based computer (901115)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you connect to a Microsoft Windows Server 2003 Service Pack 1-based computer through a Terminal Services session, the Terminal Services client computer may make a beep sound when certain events occur.

For example, this problem occurs when you start Notepad on a Terminal Services client computer, type some characters, and then close Notepad without saving the changes. A message box prompts you to save the changes that you made. The message box opens with a beep sound.

Note You experience these symptoms after you install Windows Server 2003 Service Pack 1 on a Terminal Server.

CAUSE

This issue occurs because the MessageBeep function is redirected to the Terminal Services client computer. If the Terminal Services client computer does not support audio, the beep sound is played through the system speaker.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Jun-2005  03:02  5.2.3790.346      988,672  Kernel32.dll     
   11-Jun-2005  03:02  5.2.3790.346      222,208  Termsrv.dll      
   11-Jun-2005  03:02  5.2.3790.346       52,224  Winsta.dll       
   25-Feb-2005  03:51  6.1.22.4          371,936  Updspapi.dll

Windows Server 2003 with Service Pack 1, x86-based versions

   Date         Time   Version            Size    File name 
   --------------------------------------------------------------------
   30-Jun-2005  02:35  5.2.3790.360      988,672  Kernel32.dll     
   30-Jun-2005  02:35  5.2.3790.360      222,208  Termsrv.dll      
   30-Jun-2005  02:35  5.2.3790.360       52,224  Winsta.dll       
   05-Mar-2005  01:30  6.1.22.4          371,936  Updspapi.dll  
   30-Jun-2005  03:06  5.2.3790.2477     245,248  Termsrv.dll      
   30-Jun-2005  00:58  5.2.3790.2477      32,256  Arpidfix.exe   

Windows Server 2003, Itanium-based versions

    Date         Time   Version            Size    File name       Platform
   --------------------------------------------------------------------
   10-Jun-2005  14:29  5.2.3790.346    1,851,392  Kernel32.dll     IA-64
   10-Jun-2005  14:29  5.2.3790.346      621,568  Termsrv.dll      IA-64
   10-Jun-2005  14:29  5.2.3790.346      141,824  Winsta.dll       IA-64
   10-Jun-2005  14:32  5.2.3790.346      934,912  Wkernel32.dll    x86
   10-Jun-2005  14:32  5.2.3790.346       52,224  Wwinsta.dll      x86
   24-Feb-2005  15:22  6.1.22.4          639,712  Updspapi.dll     IA-64

Windows Server 2003 with Service Pack 1, Itanium-based versions

   Date         Time   Version            Size    File name         Platform
   -----------------------------------------------------------------------
   29-Jun-2005  15:02  5.2.3790.360    1,851,392  Kernel32.dll     IA-64
   29-Jun-2005  15:02  5.2.3790.360      621,568  Termsrv.dll      IA-64
   29-Jun-2005  15:02  5.2.3790.360      141,824  Winsta.dll       IA-64
   29-Jun-2005  15:02  5.2.3790.360      934,912  Wkernel32.dll    x86
   29-Jun-2005  15:02  5.2.3790.360       52,224  Wwinsta.dll      x86
   29-Jun-2005  15:02  5.2.3790.2477     696,320  Termsrv.dll      IA-64
   29-Jun-2005  15:02  5.2.3790.2477      74,752  Arpidfix.exe     IA-64
   29-Jun-2005  15:02  6.1.22.4          639,712  Updspapi.dll     IA-64

Windows Server 2003, x64-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Jun-2005  15:02  5.2.3790.2477     363,008  Termsrv.dll      
   29-Jun-2005  15:02  5.2.3790.2477      43,008  Arpidfix.exe     
   29-Jun-2005  15:02  6.1.22.4          462,560  Updspapi.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply the hotfix, you can use the registry to enable redirection of the MessageBeep function. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableBeep, and then press ENTER.
  5. Right-click DisableBeep, and then click Modify.
  6. In the Value data box, type 0, and then click OK.

    Note You can disable the MessageBeep function by changing the value to 1.
  7. Quit Registry Editor.
For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB901115 kbAudITPRO