The recipient does not receive an attachment when an RTF e-mail message is delivered though an Exchange Server 2003 bridgehead server (901035)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

Consider the following scenario. You send a Rich Text Format (RTF) e-mail message that includes an attachment. This e-mail message is delivered to the recipient through a Microsoft Exchange Server 2003 bridgehead server.

In this situation, one of the following symptoms may occur:
  • The recipient does not receive the attachment when the e-mail is delivered.
  • The e-mail message is received in plain text format instead of in the expected RTF.
Note You do not experience this problem in Microsoft Exchange Server version 5.5.

CAUSE

This problem occurs because Exchange Server 2003 cannot handle the additional space that is in the X-MS-TNEF-Correlator field in the e-mail message. Therefore, Exchange Server 2003 cannot obtain the value of the X-MS-TNEF-Correlator field from the PR_TNEF_CORRELATION_KEY property. The PR_TNEF_CORRELATION_KEY property is encapsulated from the TNEF part of the e-mail message body.

If Exchange Server 2003 cannot obtain the value of the X-MS-TNEF-Correlator field from the PR_TNEF_CORRELATION_KEY property, the program drops the attachment of the RTF e-mail message.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1 (SP1).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   -------------------------------------------------------
   08-Jul-2005  01:55  6.5.7233.36   3,270,144  Mdbmsg.dll       
   04-Jun-2005  01:56                    3,304  Redir.asp
   08-Jul-2005  02:29  6.5.7233.36   5,177,856  Store.exe     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbQFE KBHotfixServer kbexchSTORE kbfix kbBug kbExchange2003preSP2fix kbpubtypekc KB901035 kbAudITPRO