You cannot perform actions such as search and drag when you use a Windows Server 2003-based computer (900960)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use a Microsoft Windows Server 2003-based computer, you may experience one or more of the following symptoms:
  • When you click Web page hyperlinks that are supposed to open in a new window, nothing occurs.
  • When you right-click a hyperlink on a Web page and then click Open in New Window, nothing occurs.
  • When you click a hyperlink in Microsoft Outlook or in Microsoft Outlook Express, the hyperlink does not work.
  • When you try to drag an item to the Start menu or to any folder on the system, the pointer changes to a circle that has a slash through it, and you cannot drop anything.
  • When you click Find (on This Page) on the Edit menu in Microsoft Internet Explorer, the operation may not work or may work only one time.
  • When you click Start, click Search, type all or part of a file name in the All or part of file name text box, and then click Search, nothing occurs.
  • When you click Start, click Search, click Other Search Options, and then click Search the Internet, nothing occurs.
  • When you try to start Microsoft Office Assistant, you receive the following error message:
    Problem occurred using Office Assistant, Do you want to reinstall it?
  • When you try to drag a file from Microsoft Outlook 2000 or from Microsoft Office Outlook 2003 to a folder, you receive the following error message:
    Cannot create another system semaphore.
  • You cannot print from Internet Explorer.
  • You cannot print HTML messages in Outlook.
  • When you click Start and then click Windows Update, nothing occurs.
  • When you try to download an update from the Windows Update Web site in Internet Explorer, Windows Update appears not to function. Although you see the "Preparing to Download" message, the progress indicator does not change.

CAUSE

This issue may occur if the default access permissions have been changed in the Dcomcnfg.exe tool.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this issue, locate and then delete the DefaultAccessPermission registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole

  3. In the right pane, right-click DefaultAccessPermission, and then click Delete.
  4. In the Confirm Value Delete dialog box, click Yes.
  5. Exit Registry Editor.
  6. Log off the computer, and then log back on to the computer.

MORE INFORMATION

For more information about issues that are related to default access permissions settings in Dcomcnfg.exe in Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

274696 Actions such as search and drag and drop do not work because the default access permissions have been changed in the Dcomcnfg.exe tool


Modification Type:MajorLast Reviewed:8/10/2005
Keywords:kbwinservsetup kbwinservnetwork kbwinupdwebsite kbpermissions kbbrowsing kbtshoot KB900960 kbAudEndUser kbAudITPRO