You receive an "A program has not started. Please try again" error message if you try to start Remote Assistance on a Windows XP Service Pack 2-based computer (900904)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Home Edition

SYMPTOMS

If you try to start a Remote Assistance session on a computer that is running Microsoft Windows XP Service Pack 2 (SP2), you may receive the following error message:
A program has not started. Please try again.
Additionally, if you click Start to start the Remote Desktop Help Session Manager service, you may receive the following error message:
The Remote Desktop Help session manager did not start properly (error code 0x80070005).

CAUSE

This issue can occur if either of the following conditions are true:
  • The Remote Desktop Help Session Manager service is not installed or is set to start automatically.
  • Remote Assistance is disabled.

RESOLUTION

To resolve this issue, use one of the following methods.

The Remote Desktop Help Session Manager service is not installed or is set to start automatically

  1. Click Start, click Run, type sysdm.cpl in the Open box, and then click OK.
  2. On the Remote tab, click to select the Allow Remote Assistance invitations to be sent from this computer check box.
  3. Click OK.
  4. Click Start, click Run, type compmgmt.msc in the Open box, and then click OK.
  5. Expand Services and Applications, and then click Services.
  6. In the right pane, right-click Remote Desktop Help Session Manager, and then click Properties.
  7. On the General tab, click Manual next to Startup type, and then click Apply.
  8. Under Service status, click Start, and then click OK.

    If the Remote Desktop Help Session Manager service is not listed, install the Remote Desktop Help Session Manager service. To install the Remote Desktop Help Session Manager service, click Start, click Run, type sessmgr.exe -service in the Open box, and then click OK.

Remote Assistance is disabled

To resolve this issue, follow these steps to restart the computer in Safe mode, and then run the sessmgr.exe -service command:
  1. Restart the computer.
  2. During the restart process, press F8.

    Note On a computer that is configured to start multiple operating systems, press F8 when the Startup menu appears.
  3. Use the arrow keys to select a Safe mode option, and then press ENTER.
  4. Click Start, click Run, type sessmgr.exe -service in the Open box, and then click OK.

Modification Type:MajorLast Reviewed:7/6/2005
Keywords:kbtshoot kbprb KB900904 kbAudEndUser