You may receive an error message when you try to download a file that is larger than 50000000 bytes from a Web folder on a computer that is running Windows XP with Service Pack 1 or with Service Pack 2 (900900)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition



Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You try to download a file that is larger than 50000000 bytes from a Web folder on a Microsoft Windows XP Service Pack 2 (SP2)-based computer. You may receive an error message that is similar to the following:
Cannot Copy FileName: Cannot read from the source file or disk
Note In this error message, FileName is a placeholder for the name of the file.

This problem also occurs on a Windows XP Service Pack 1 (SP1)-based computer that has security update 896426 (MS05-028) installed

CAUSE

This issue occurs because a security change in Windows XP SP2 affects the Web Distributed Authoring and Versioning (WebDAV) redirector. This security change makes sure that an unauthorized server cannot force a client computer into a denial of service attack. If you try to download a file that is larger than 50000000 bytes, the client computer interprets this download as a denial of service attack. Therefore, the download process stops.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this issue, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. In the right pane, right-click the FileSizeLimitInBytes value, and then click Modify.

    If you cannot see the FileSizeLimitInBytes value, right-click the blank space in the right pane, click New, click DWORD Value, type FileSizeLimitInBytes, and then click OK.
  4. In the Edit DWORD Value box, click to select the Decimal option. In the box under Value data, type a value that is larger than the size of the file that you want to download. Click OK.

    Note The default value for the file size limit is 50000000 bytes.
  5. Quit Registry Editor. Restart the computer.

Modification Type:MajorLast Reviewed:10/10/2005
Keywords:kbprb kbtshoot KB900900 kbAudEndUser