IP addresses that are assigned to a DHCP client in a Windows XP environment are marked as BAD_ADDRESS in the DHCP server address lease table (900476)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

Some of the IP addresses that are assigned to a DHCP client in a Microsoft Windows XP environment are marked as BAD_ADDRESS in the DHCP server address lease table. This issue occurs even though the IP addresses that are assigned to a DHCP client are not duplicates.

For example, this issue may occur when you perform the following procedure on a network that has a DHCP server:
  1. You disconnect the network cable from the computer when the computer is turned on.
  2. In the TCP/IP properties of the current network adaptor, you set a static IP address.
  3. You connect the network cable and then verify connectivity.
  4. You disconnect the network cable again.
  5. In the TCP/IP properties of the current network adaptor, you change the IP configuration back to Obtain an IP address automatically.
  6. You connect the network cable again.
Note This issue does not occur if you shut down the computer in the standard manner or if you release the static IP address before you disconnect the network cable.

CAUSE

This issue occurs if the Windows XP-based DHCP Client service sends incorrect DHCP decline information after you change the TCP/IP address configuration from a static address to a DHCP address. In this situation, other network devices may also start responding to all Address Resolution Protocol (ARP) requests, even though these devices are not configured to use the IP address for which the ARP request is made.

WORKAROUND

To work around this issue, use one of the following methods.

Method 1: Troubleshoot the problems in DHCP functionality

  1. View the DHCP log to determine which computers or other hardware components are causing the BAD_ADDRESS registrations. Remove these components from the network, one at a time, to determine whether a particular component is causing the issue. You can do this by viewing the switch logs to locate the port to which a component's MAC address is connected.

    Note These other hardware components may include routers, switches, or network adaptors.
  2. Correct any related problems in the computers or other hardware components in question.
  3. Delete the BAD_ADDRESS registration marks from the DHCP server address lease table.

    Note This procedure must be performed by a network administrator.

Method 2: Set an alternate IP address in the network connection TCP/IP properties

You can specify an IP address for the DHCP client in the Alternate Configuration settings so that the computer will use a static IP address when there is no DHCP server available on the network. To configure the Alternate Configuration settings, follow these steps:
  1. Click Start, click Run, type ncpa.cpl in the Open box, and then click OK.
  2. Right-click Local Area Connection, and then click Properties.
  3. In the This connection uses the following items list, double-click Internet Protocol (TCP/IP).
  4. Click the Alternate Configuration tab, and then click User configured.
  5. In the IP address box, type a valid IP address.
  6. In the Default gateway box, type a valid default gateway IP address.
  7. In the Preferred DNS server box, type the preferred DNS server IP address.
  8. In the Alternate DNS server box, type the alternate DNS server IP address.

    Note You can obtain the DNS server addresses from your Internet service provider (ISP) or network administrator. The computer is now configured to use this static IP address when the DHCP server is unavailable.

Modification Type:MajorLast Reviewed:12/23/2005
Keywords:kbtshoot KB900476 kbAudITPRO kbAudEndUser