Print spooling operation in Windows Server 2003-based Terminal Services (TS) computer is slow when Remote Desktop Connection thin clients use printer redirection (900090)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

SYMPTOMS

The print spooling operation on a Microsoft Windows Server 2003-based Terminal Services (TS) computer may be slow if a thin client such, as a Microsoft Windows CE-based computer,redirects the local printers.

Note You do not experience this problem on a fat client. An example of a fat client is a Microsoft Windows XP-based computer.

CAUSE

This problem occurs if one of the locally attached printer devices is experiencing an error condition. The error condition then blocks all other jobs from acquiring the necessary file control block (FCB). The error condition also prevents all redirected printers from sending jobs to the thin clients.

The print spooling operation resumes at typical speed as soon as the error condition on the printer device is resolved.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 Service Pack 1 (SP1) installed.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2485641,53612-Jul-200504:17IA-64
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2485332,80012-Jul-200504:17x64
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2485200,19212-Jul-200501:21x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/23/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB900090 kbAudITPRO