Printing Problems with XNSNB (90176)



The information in this article applies to:

  • Microsoft LAN Manager 2.1

This article was previously published under Q90176

SYMPTOMS

If you are connecting to a printer share using the XNSNB protocol,you may experience problems when you attempt to print from MS-DOS applications such as Harvard Graphics, FoxPro, and MS-DOS PRINT. Usually printing from these applications will cause the workstation to enter a perpetual beeping state. If this happens, you will need to reboot to get out of this state. On the server, either a print job of zero length or no print job at all will appear in the queue.

CAUSE

XNSNB was developed by 3Com Corporation. 3Com has determined that there is a problem in XNSNB with the way that it chains the timer interrupt.

RESOLUTION

Change the order that the workstation service and XNSNB are loaded. In a default configuration, this means changing the following lines in the AUTOEXEC.BAT file from:

NET START WORKSTATION LOAD XNSNB

to:

LOAD XNSNB NET START WORKSTATION

The result is that the LAN Manager workstation service will appear in the interrupt chain before XNSNB, avoiding the chaining problem in XNSNB entirely. Unfortunately, this results in the inability to unload and reload XNSNB dynamically.

STATUS

3Com Corporation has confirmed this to be a problem in XNSNB 2.0 that is shipped in the Microsoft Upgrade Toolkit for 3Com Networks version 2.0. They are currently researching this problem. We will post new information here as it becomes available.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:KB90176