ACC: "Couldn't Find Installable ISAM" Error Message (90111)
The information in this article applies to:
- Microsoft Access 2.0
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q90111
Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
If you try to import, export, or link (attach) a file by using an indexed
sequential access method (ISAM) driver, you may receive an error message
if Microsoft Access cannot find the ISAM driver.
CAUSE
ISAM drivers are used by Microsoft Access to update file formats other
than its own.
In Microsoft Access 2.0, if the path to the ISAM driver in your
Msacc20.ini file is invalid, or if the ISAM driver does not exist, you may
receive the following error message:
Couldn't find installable ISAM.
Microsoft Access 7.0 and 97 do not have an .ini file. Information
previously stored in the .ini files is now stored in the Microsoft Windows
Registry. In Microsoft Access 7.0 and 97, if the path to the ISAM driver
in your Windows Registry is invalid, or if the ISAM driver does not exist,
you may receive the following error message:
Couldn't find installable ISAM.
This error can also occur if you enter an invalid database name for a
SQL database when you are using the TransferDatabase action in a macro.
When you use an invalid connect string, Microsoft Access looks for an
installable ISAM for the SQL database. If an installable ISAM cannot be
located, an error occurs.
RESOLUTION
In Microsoft Access 2.0, edit the .ini file to specify the correct path in
the [Installable ISAMs] section, or reinstall Microsoft Access using the
Custom option. For troubleshooting tips related to this error message in
Microsoft Access 2.0, please see the following article in the Microsoft
Knowledge Base:
150494 ACC2: Troubleshooting "Can't Find Installable ISAM" Error
In Microsoft Access 7.0 or 97, you can edit the Windows Registry. For more
information on registry changes, search for "Registry," and then
"Customize Windows Registry settings used by Microsoft Access" using the
Microsoft Access 97 Help index. For troubleshooting tips related to this
error message in Microsoft Access 7.0, please see the following
article in the Microsoft Knowledge Base:
155666 ACC95: Troubleshoot "Couldn't Find Installable ISAM" Error
For information about the ISAM drivers in Microsoft Access 97, please see
the following article in the Microsoft Knowledge Base:
159322 ACC97: Paradox, Lotus, & MS Exchange/Outlook ISAMs in
ValuPack
STATUS
This behavior is by design.
REFERENCES
For more information about the TransferDatabase action, type
TransferDatabase in the Office Assistant, click Search, and then click
to view "TransferDatabase Action."
Modification Type: | Major | Last Reviewed: | 5/9/2003 |
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Keywords: | kberrmsg kbprb kbusage KB90111 |
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