Volume mount points on disks in a server cluster may intermittently become unavailable after you install Windows Server 2003 Service Pack 1 (898790)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

After you install Microsoft Windows Server 2003, Enterprise x64 edition or Windows Server 2003 Service Pack 1 (SP1) on a server cluster, you experience all the following symptoms:
  • Volume mount points that you have configured on shared disks in a server cluster may intermittently become unavailable.
  • If you move the shared disk resources on the affected cluster node to a different cluster node or if you restart the affected cluster node, some or all the volume mount points may again become available.
  • If you run the Mountvol command to view the available mount points, you experience one of the following symptoms:
    • The GUID of the unavailable mount point does not appear in the results of the Mountvol command.
    • The GUID of the unavailable mount point appears in the results of the Mountvol command. However, the following information appears for this GUID:

      *** No Mount Points***

  • If you use Windows Explorer to click the folder that corresponds to the mount point, you experience one of the following symptoms:
    • The folder opens in Windows Explorer.
    • You receive the following error message:
      Mount Point Path refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location.
    Note If a problem exists with a volume mount point, you expect to receive this error message. You do not expect the folder to open successfully.

CAUSE

This problem occurs because of a problem in the Mountmgr.sys driver. This problem is an intermittent timing problem that may occur when a volume arrives to be mounted to a mount point.

Note Generally, this problem does not occur in a non-clustered environment. In a non-clustered environment, the timing of the volume mount process is different.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  01:34  5.2.3790.2443      46,592  Mountmgr.sys
Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  03:50  5.2.3790.2443      72,192  Mountmgr.sys
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  03:50  5.2.3790.2443     155,648  Mountmgr.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB898790 kbAudITPRO