The Spooler service may stop responding on a Windows Server 2003-based print server (898788)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use a Microsoft Windows Server 2003-based computer as a print server, the Spooler service may stop responding. Additionally, print jobs are not completed.

CAUSE

This problem may occur if the print server receives many requests for printer driver information from many client computers at the same time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 (32-bit editions)

File nameFile versionFile sizeDateTimePlatformService branch
Localspl.dll5.2.3790.386312,32011-Aug-200502:29x86RTMQFE
Spoolss.dll5.2.3790.38681,92011-Aug-200502:29x86RTMQFE

Windows Server 2003, 64-Bit Enterprise Edition

File nameFile versionFile sizeDateTimePlatformService branch
Localspl.dll5.2.3790.386860,67211-Aug-200503:25IA-64RTMQFE
Spoolss.dll5.2.3790.386235,00811-Aug-200503:25IA-64RTMQFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbExpertiseInter kbWinServ2003preSP2fix kbBug kbfix kbpubtypekc KB898788 kbAudITPRO