A third-party MAPI program stops responding, and Exchange Server 2003 intermittently does not deliver messages (898782)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you use a third-party MAPI program in Microsoft Exchange Server 2003, over time, the third-party MAPI program stops responding. Additionally, Exchange Server 2003 intermittently does not deliver messages. During this period, if you monitor memory usage for the MAPI program, you find that there is a steady increase in memory usage until no free system memory is available. Eventually, you have to restart the Microsoft Exchange Information Store service (Store.exe) to resume using the MAPI program and the Exchange messaging services.

CAUSE

This problem occurs if the third-party MAPI program logs on to a mailbox and then makes repeated calls to the OpenMsgStore method to open additional Exchange mailboxes. Memory is leaked in each call until no free system memory is available.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 1 (SP1) must be installed before you install the hotfix.

Restart requirement

You do not have to restart the computer after you install the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Jul-2005  02:02  6.5.7233.36     1,320,960  Emsmdb32.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE KBHotfixServer kbExchange2003preSP2fix kbfix kbBug kbpubtypekc KB898782 kbAudITPRO