You receive a "Remote computer has ended the connection" error message when you use the remote desktop connection tool on a Windows XP SP2-based computer (898713)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP2

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2) on a computer that is running Windows XP, you cannot connect to a remote computer by using the remote desktop connection tool. Additionally, you receive the following error message:
The remote computer has ended the connection

CAUSE

This problem occurs when Distributed File Systems (DFS) Client functionality is disabled in the following registry subkey on a Windows XP SP2-based computer:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mup

When DFS is disabled on a Windows XP SP2-based computer, the Remote Desktop Protocol (RDP) causes the connection to fail.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, you must have Windows XP SP2 installed to install this hotfix requires.

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.1.2600.2689195,20002-Jun-200501:42x86

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To work around this problem, re-enable the DFS client in the registry. To do this, follow these steps.
  1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. In Registry Editor, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mup

  3. In the details pane on the right, double-click DisableDFS. If the value in the Value data box is 1, the DFS client is disabled. If the value in the Value data box is 0, the DFS client is enabled.
  4. In the Edit DWORD Value dialog box, type 0 in the Value data box, and then click OK.
  5. On the File menu, click Exit to quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinXPsp2fix kbfix kbbug kbHotfixServer kbQFE kbpubtypekc KB898713 kbAudITPRO