FIX: A crash dump file is not generated after a fatal system error occurs on a computer that is running Windows Server 2003 Service Pack 1 (898620)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

When a fatal system error occurs on a computer that is running Microsoft Windows Server 2003 Service Pack 1 (SP1), a crash dump file is not generated as you expect. This symptom occurs when the following conditions are true:
  • There is already a Memory.dmp file on the same path that you have configured for the system crash dump file and for the page file.
  • The crash dump file is generated on a volume that is not the boot volume.
  • You have sufficient free space on the volume that you configured to generate crash dump files.
  • The Overwrite the existing dump file option is enabled.

CAUSE

This problem occurs because the session manager incorrectly calculates the free disk space that is required on the target volume. Specifically, the session manager does not consider the disk space that is used for existing dump files when it calculates the total disk space that is required for crash dump files.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 SP1 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 with SP1, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2005  02:53  5.2.3790.2432     152,576  Smss.exe         IA-64
   29-Apr-2005  02:53  5.2.3790.2432      53,760  Wsmss.exe        x86
Windows Server 2003 with SP1, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2005  01:26  5.2.3790.2432      53,760  Smss.exe    
Windows Server 2003 x64 Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2005  02:53  5.2.3790.2432      75,264  Smss.exe         x64
   29-Apr-2005  02:53  5.2.3790.2432      53,760  Wsmss.exe        x86
Note Service Pack 1 is already included in Windows Server 2003 x64 Edition.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To enable the Overwrite the existing dump file option, follow these steps:
  1. Click Start, right-click My Computer, and then click Properties.
  2. Click the Advanced tab.
  3. Under Startup and Recovery, click Settings.
  4. Click to select the Overwrite any existing file check box.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE kbpubtypekc KB898620 kbAudDeveloper kbAudITPRO