You may experience slow performance in Windows XP SP2 when you use the Favorites menu in Internet Explorer or in Windows Explorer (898612)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)


Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2) or the hotfix that is described in Microsoft Knowledge Base (KB) article 840309, you may experience slow performance. This symptom occurs when you use the Favorites menu in Microsoft Internet Explorer or in Windows Explorer.

CAUSE

This issue may occur if the following conditions are true:
  • You redirect the My Documents folder to a network location.
  • After you install Windows XP SP2 or the hotfix in KB article 840309, you enable the Desktop.ini cache.
The Desktop.ini cache process is designed to cache only Desktop.ini files that reside in network share locations. However, this process may instead cache all files that are opened through the GetPrivateProfileString function. This increased cache load causes slow performance.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this software update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP Service Pack 1, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-May-2005  17:14  6.0.2800.1692   8,348,160  Shell32.dll      
   25-May-2005  00:23  5.1.2600.1692     594,432  Xpsp2res.dll     
   20-Aug-2004  22:01  6.0.2800.1579      82,432  Fldrclnr.dll     
   25-May-2005  17:14  6.0.2800.1692     408,576  Shlwapi.dll      
   20-Aug-2004  22:01  5.1.2600.1579     700,928  Sxs.dll   
Windows XP Service Pack 1, 64-bit version (Itanium)
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Aug-2004  06:52  6.0.2800.1579     130,560  Fldrclnr.dll     IA-64
   25-May-2005  02:10  6.0.2800.1692  14,396,928  Shell32.dll      IA-64
   25-May-2005  02:10  6.0.2800.1692   1,117,696  Shlwapi.dll      IA-64
   20-Aug-2004  06:52  5.1.2600.1579   2,034,176  Sxs.dll          IA-64
   24-May-2005  09:40  5.1.2600.1692     593,920  Xpsp2res.dll     IA-64
   25-May-2005  02:10  6.0.2800.1692   2,649,088  Comctl32.dll     IA-64
   25-May-2005  02:14  6.0.2800.1692     925,184  Comctl32.dll     x86
   20-Aug-2004  07:01  6.0.2800.1579      82,432  Wfldrclnr.dll    x86
   25-May-2005  02:14  6.0.2800.1692   8,348,160  Wshell32.dll     x86
   25-May-2005  02:14  6.0.2800.1692     408,576  Wshlwapi.dll     x86
   20-Aug-2004  07:01  5.1.2600.1579     700,928  Wsxs.dll         x86
   24-May-2005  09:23  5.1.2600.1692     594,432  Wxpsp2res.dll    x86
Windows XP Service Pack 2, 32-bit versions
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-May-2005  17:05  6.0.2900.2684   8,452,096  Shell32.dll      
   25-May-2005  17:05  6.0.2900.2684     473,600  Shlwapi.dll      
   24-May-2005  23:33  5.1.2600.2684      17,920  Xpsp3res.dll

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To work around this problem, use one of the following methods.

Method 1: Move the My Documents folder back to the local computer.

Method 2: Disable the Desktop.ini cache. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer

  3. In the right pane of Registry Editor, right-click UseDesktopIniCache, and then click Modify.
  4. In the Edit DWORD Value dialog box, type 0 under Value data, and then click OK.
  5. Quit Registry Editor.
  6. Restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the hotfix that is mentioned in the "Symptoms" section, click the following article number to view the article in the Microsoft Knowledge Base:

840309 Browsing the My Documents folder on a network share with Windows Explorer from a Windows XP-based computer takes longer than expected


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug kbpubtypekc KB898612 kbAudEndUser