Programs that you open appear to stop responding in Windows Server 2003 (898606)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

If you start a program on a Microsoft Windows Server 2003-based computer, the program takes a long time to start. Therefore, the program appears to stop responding. This symptom occurs if the Windows Server 2003-based computer is under a heavy load. Additionally, a program that is associated with the program that you start also appears to stop responding. The associated program appears to stop responding for the same period of time as the first program that you started. For example, you start Windows Explorer to locate a text file. After you double-click the text file to view the text file in Notepad, both Windows Explorer and Notepad appear to stop responding. It may take 15 minutes for the programs to start responding again.

Note
  • Programs appear to stop responding even though the processor load is 10 to 15 percent and the system disk is almost idle.
  • Typically, the Explorer.exe program is the associated program that appears to stop responding.

CAUSE

This problem occurs if the Windows Server 2003-based computer experiences lots of Input/Output (I/O) traffic. For example, the Windows Server 2003-based computer experiences lots of I/O traffic if many File Transfer Protocol (FTP) connections are performing upload and download operations. The upload and download operations use I/O resources that include the Cache Manager. The Cache Manager is not disk-based, and the Cache Manager operates globally. Therefore, the problem occurs even if almost no load on the system disk exists. The high I/O traffic causes the cached disk transfers to build up. These cached disk transfers cause any read requests that are required to start new programs to stall. The read requests are delayed until the queue of cached disk transfers is cleared.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 x86-based versionThe following hotfix files are installed on a computer that has Windows Server 2003 Service Pack 1 (SP1) installed:
  Date        Time       Version        Size        File name
---------------------------------------------------------------------------
29-Apr-2005   22:27   5.2.3790.2433    2,452,992   Ntkrnlmp.exe
29-Apr-2005   16:16   5.2.3790.2433    2,266,624   Ntkrnlpa.exe 
29-Apr-2005   21:57   5.2.3790.2433    2,307,072   Ntkrpamp.exe
29-Apr-2005   22:27   5.2.3790.2433    2,414,592   Ntoskrnl.exe 

The following hotfix files are installed on a computer that does not have any Windows Server 2003 service pack installed:


Date        Time       Version        Size        File name
---------------------------------------------------------------------------
30-Apr-2005   00:38   5.2.3790.321     2,408,448   Ntkrnlmp.exe
29-Apr-2005   21:08   5.2.3790.321     2,065,408   Ntkrnlpa.exe   
29-Apr-2005   21:08   5.2.3790.321     2,110,464   Ntkrpamp.exe   
30-Apr-2005   00:21   5.2.3790.321     2,208,256   Ntoskrnl.exe    
Windows Server 2003 x64-based version
  Date      Time     Version         Size        File name
--------------------------------------------------------------
29-Apr-2005 16:17   5.2.3790.2433   4,416,512   Ntkrnlmp.exe 
29-Apr-2005 16:17   5.2.3790.2433   4,443,648   Ntoskrnl.exe 
Windows Server 2003 Itanium-based version
  Date      Time     Version         Size        File name
--------------------------------------------------------------
29-Apr-2005   16:17   5.2.3790.321   5,608,448   Ntkrnlmp.exe   IA-64
29-Apr-2005   16:17   5.2.3790.2433  6,477,312   Ntkrnlmp.exe   IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install the hotfix, the cache manager prioritizes I/O requests that are related to new processes and bypasses the cache managers regular work queue.

For more information about the description of the standard terminology that is used to describe Microsoft updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix kbpubtypekc KB898606 kbAudITPRO