Event ID 30983 is repeatedly logged on a Live Communications Server 2005 front-end server after you restart another front-end server in your enterprise pool (898517)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

In a Microsoft Office Live Communications Server 2005 deployment, multiple front-end servers communicate with a back-end database server. In this scenario, you may experience the following symptoms after you restart a Live Communications Server 2005 front-end server in your enterprise pool:
  • Another Live Communications Server front-end server no longer communicates with the front-end server that you restarted.
  • The following event is repeatedly logged in the Application event log of the front-end server that you restarted:
    Event Type: Error
    Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 30983
    Date: date
    Time: time
    User: N/A
    Computer: computer_name
    Description: An RPC call to deliver notifications to the target server failed.

    Target server: ServerName.example.com. Error code 6BE
    Resolution: Ensure that the target server is running.

    For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem may occur on a heavily loaded front-end server. In Live Communications Server 2005, front-end servers communicate with each other by using asynchronous remote procedure calls (RPCs). In Microsoft Windows Server 2003, some RPC binding handles may be leaked if the destination Live Communications Server service of an RPC call is stopped and then restarted.

Note You are experiencing the problem that is described in the "Symptoms" section only if event 30983 is repeatedly logged at five-minute intervals.

RESOLUTION

To resolve this problem, install Windows Server 2003 Service Pack 1 (SP1) on the front-end servers in your Live Communications Server 2005 deployment. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

WORKAROUND

To work around this problem, restart the Live Communications Server service on the front-end server on which you experience this problem. To do this, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the Services dialog box, right-click Live Communications Server, and then click Restart.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbtshoot kbprb KB898517 kbAudITPRO