The ScsiStatus member of the SCSI_PASS_THROUGH structure does not contain error status information on a computer that is running Windows Server 2003 or Windows 2000 (898465)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003 or Microsoft Windows 2000, the ScsiStatus member of the SCSI_PASS_THROUGH structure does not contain error status information. The error status is not copied to the user when an error occurs. This problem can cause different issues, depending on the product that uses pass-through authentication.

CAUSE

This problem occurs because there is a error in the Scsiport.sys file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.2.3790.432127,48825-Oct-200523:53x86
Windows Server 2003 with SP1, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.2.3790.2556104,96026-Oct-200500:50x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.2.3790.2556170,49625-Oct-200511:05x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.2.3790.432292,35225-Oct-200511:05IA-64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.2.3790.2556317,44025-Oct-200511:05IA-64
Windows 2000
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys5.0.2195.707174,67219-Sep-200523:22x86

Hotfix installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then right-click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ScsiPort

  3. Point to New, click DWORD Value, and then type ScsiStatus.
  4. Right-click ScsiStatus, click Modify, and then type 1 in the Value data box.
  5. Exit Registry Editor.
  6. Restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE kbpubtypekc KB898465 kbAudITPRO