You receive a "The following message could not be delivered to all recipients" error message when you send an instant message to a user in Live Communications Server 2005 Enterprise Edition (898150)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition
  • Microsoft Office Live Communications Server 2005 Standard Edition

SYMPTOMS

After you configure Microsoft Windows Messenger to connect to a computer that is running Microsoft Office Live Communications Server 2005 Enterprise Edition, you experience all the following symptoms:
  • You can sign in to Live Communications Server.
  • The presence information appears correctly for the Windows Messenger contacts.
  • When you try to send an instant message to a contact by using Windows Messenger, you receive the following error message:
    The following message could not be delivered to all recipients:
    message text

CAUSE

Live Communications Server 2005 introduces the concept of a pool. A pool is a logical collection of front-end and back-end Live Communications Server computers. When you configure Live Communications Server, you must manually add a host record to the Domain Name System (DNS) for your Live Communications Server pool.

This issue that is described in the "Symptoms" section occurs if Windows Messenger is not configured to communicate with the Live Communications Server 2005 Enterprise Edition pool. For example, this issue occurs if you specify that the Live Communications Server host name or IP address in the Server name or IP address box of the SIP Communications Service Connection Configuration dialog box in Windows Messenger.

When users communicate with other users in Live Communications Server 2005 Enterprise Edition, Live Communications Server includes the name of the pool in the Record-Route field of the Live Communications Server network traffic. If the client computer that is running Windows Messenger cannot resolve this pool name in DNS, the Windows Messenger communications are not successful.

Note This issue only occurs in Live Communications Server 2005 Enterprise Edition. You do not experience this issue with Live Communications Server 2005 Standard Edition or with Microsoft Office Live Communications Server 2003.

RESOLUTION

To resolve this issue, add a host record for the Live Communications Server Enterprise Edition pool to DNS, and then configure Windows Messenger to connect to that pool. To do this, follow these steps:

Step1: Add a host record to DNS

  1. On the DNS server, click Start, click Run, type dnsmgmt.msc, and then click OK.
  2. Expand your DNS server, expand Forward Lookup Zones, right-click your domain, and then click New Host (A).
  3. In the Name (uses parent domain name if blank) box, type the host name of your Live Communications Server pool. For example, type pool-1.
  4. In the IP address box, type the IP address that you want to assign to the Live Communications Server pool, and then click Add Host.
  5. When you receive the following message, click OK:

    The host record poolname.example.com was successfully created.
  6. Click Done.

Step 2: Configure Windows Messenger to connect to the pool

  1. On the client computer that is running Windows Messenger, click Start, click Run, type cmd, and then click OK.
  2. Type ipconfig /flushdns, and then press ENTER.
  3. Type ipconfig /registerdns, and then press ENTER.
  4. Start Windows Messenger, and then sign out of the Session Initiation Protocol (SIP) Communications Service if you are signed in.
  5. On the Tools menu, click Options.
  6. Click the Accounts tab, and then click Advanced next to the My contacts include users of a SIP Communications Service command.
  7. Click Configure settings, and then type the fully qualified domain name of your Live Communications Server 2005 Enterprise Edition pool in the Server name or IP address box. For example, type pool-1.example.com.
  8. Under Connect using, click the kind of transport protocol that you deployed with Live Communications Server. For example, click TCP.
  9. Click OK two times.
Note To use the Automatic configuration option in the SIP Communications Service Connection Configuration dialog box in Windows Messenger, you must create service location records for the SIP communications Service in DNS. For more information about how to configure these service location records, click the following article number to view the article in the Microsoft Knowledge Base:

898153 "An HTTPS or TCP connection could not be made" error message when you try to connect to an Office Live Communications Server 2003 Home Server or to an Office Live Communications Server 2005 pool by using Windows Messenger

MORE INFORMATION

You can view the contents of the Record-Route field if you enable client-side tracing. For more information about how to enable client-side tracing in Windows Messenger, click the following article number to view the article in the Microsoft Knowledge Base:

871023 Using the Windows Messenger 5.0 debug log to troubleshoot sign-in failures in Live Communications Server 2003

For more information about how to configure and deploy Live Communications Server, see the Live Communications Server Deployment Resources. To obtain the Live Communications Server Deployment Resources, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/2/2005
Keywords:kbtshoot kbprb KB898150 kbAudITPRO