You receive a "this letter template is not valid" error message in Small Business Accounting when you use a mail merge template that you created by using fields from Business Contact Manager. (897876)



The information in this article applies to:

  • Microsoft Office Small Business Accounting 2006
  • Microsoft Office Small Business Management Edition 2006

SYMPTOMS

In Microsoft Office Small Business Accounting, you receive the following error message when you use a mail-merge template that you created by using fields from Microsoft Office Outlook 2003 Business Contact Manager:

This letter template is not valid. There are no valid mail merge fields in this template.

CAUSE

When you use the Write Letters Wizard in Small Business Accounting to create a mail-merge template, the fields in the template are from Business Contact Manager. Therefore, they do not exist in Small Business Accounting.

RESOLUTION

To resolve this problem, replace the Business Contact Manager fields in the mail-merge template with the corresponding Small Business Accounting fields. To do this, follow these steps:
  1. On the Customers menu, click Write Letters to open the Write Letters Wizard.
  2. Review the steps that are listed, and then click Next.
  3. On the Recipient list, click Customer.
  4. Drag the pointer to select the template that you created, and then click Modify. Microsoft Word opens the template and then lists the merge fields.
  5. Drag the pointer to select the merge field that you want to replace.
  6. On the toolbar, click the Insert Merge Field button.
  7. Click Database Field, and then select a field to replace the merge field that you selected in step 5.
  8. Click Insert, and then click Close.
  9. Repeat steps 5 through 8 for all fields that you want to replace.
  10. On the File menu, click Exit to close the Word mail-merge template.
  11. Click Yes when Word prompts you to save the changes.

    Note If the template exists, Word prompts you about whether you want to replace the existing template. Click Yes to replace it, or click No to save it with a different name. If the template is read-only, a Save As window appears. You may then save the template by using a different name.

    Note The default location for customer letter templates is C:\Program Files\Microsoft Small Business\Small Business Accounting\Letters\Customer.
  12. Click Next to continue to use the Write Letters Wizard.
  13. Try to use the template again.

MORE INFORMATION

Steps to reproduce the problem

  1. On the Small Business Accounting main menu, click Business Tools, and then click either Accounts or Business Contacts.
  2. On the Tools menu, click Mail Merge.
  3. In the Mail Merge Contact window, accept the default selections.
  4. Click OK to open a new Word template that has the Mail Merge toolbar.
  5. In the template, position your pointer in the location at which you want to insert a field.
  6. On the toolbar, click the Insert Merge Field button.
  7. Click Database Field, drag the pointer to select the field that you want to insert in the template, and then click Insert.
  8. Repeat steps 5 through 7 for all remaining required fields.
  9. Click OK to close the Insert Merge Field window.
  10. On the toolbar, click the View Merged Data button to make sure that you pulled the data from the Business Contact Manager contact list.

    Note If a selected field has no data, that field is blank when you view the merged data. For example, if you add the Business_Fax field to the template, but the account in Business Contact Manager does not contain a fax number, the Business_Fax field is blank.
  11. On the File menu, click Save As, and then find the following folder in the Save in box:

    C:\Program Files\Microsoft Small Business\Small Business Accounting\Letters\Customer
  12. In the File name box, enter a file name for the template, and then click Save.
  13. In Small Business Accounting, click Company, and then click Write Letters to open the Write Letters Wizard.
  14. Click Next.
  15. Click Customer if Customer is not already selected.
  16. Click the template that you saved in step 12.
  17. Click Next.
  18. Click the customers who will receive the letter, and then click Next.
  19. Make any required changes to the signature, and then click Create Letters. You receive the error message that is mentioned in the "Symptoms" section.

Modification Type:MinorLast Reviewed:8/10/2005
Keywords:kberrmsg kbprb KB897876 kbAudEndUser