You receive the "Project Server encountered a problem with this error code: 9415" error message when you try to log on to Project Professional 2003 by using manager permissions (897768)



The information in this article applies to:

  • Microsoft Office Project Server 2003
  • Microsoft Office Project Professional 2003

SYMPTOMS

You receive the following error message when you try to log on to Microsoft Office Project Professional 2003 by using manager permissions:
An error occurred in the Project Server.

Project Server encountered a problem with this error code: 9415. Please contact your server administrator.
Then, after you click OK, you receive the following error:
Cannot Connect.

Microsoft Project was unable to establish a connection to the selected Project Server. This could be caused by a loss of network connectivity invalid user name or password, lack of an enterprise global template, or problems with the Project Server or database, or your Project Server may not have enterprise features enabled.

CAUSE

This issue can occur if the CODE_UID value for the user account in the MSP_CODE_FIELDS table has a NULL value and the CODE_FIELD_ID value is 205521540. Additionally, this issue can occur if the Enterprise Global was not successfully saved or if the Enterprise Global is corrupted. The CODE_FIELD_ID 205521540 refers to the Resource Breakdown Structure (RBS) code. Typically, the MSP_CODE_FIELDS table does not contain records for resources where the CODE_FIELD_ID value is 205521540 and the RBS Code is not set.

RESOLUTION

To resolve this issue, use one of the following methods. We recommend that you use the methods in the order that they appear in this article.

Method 1: Open and then close the Enterprise Resource Pool

To use this method, you must remove the NULL records in the MSP_CODE_FIELDS table. To do this, follow these steps:
  1. Log on to Microsoft Office Project Professional 2003 by using a user account that has Manage users and groups permissions.
  2. On the Tools menu, point to Enterprise Options, and then click Open Enterprise Resource Pool.
  3. At the bottom of the Open Enterprise Resources dialog box, click Read/Write to check out, and then click Open/Add.
  4. On File menu, click Close.
Note This method corrects the issue for all accounts.

Method 2: Manually correct the user account in Microsoft Office Project Web Access

You can use Project Web Access (PWA) to correct individual accounts that experience this issue. To do this, follow these steps:
  1. Log on to Microsoft Office Project Web Access by using a user account that has administrator permissions.
  2. Click Admin on the toolbar to open the Administration Overview page, and then click Manage users and groups.
  3. Click the user account that is experiencing this issue in the user list, and then click Modify User.
  4. On the Modify User page, click Save Changes.
Note This method can be tedious if you have many accounts that are experiencing this issue.

Method 3: Run a script to remove the NULL values from the MSP_CODE_FIELDS table

Use Query Analyzer on the SQL Server to run the following script. This script removes the NULL record values for the resources.

Note We recommend that you follow these steps only if the other methods in this article do not resolve the issue.
  1. On the computer that is running SQL Server, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  2. On the Query menu, click Change Database, click the Project Server database, and then click OK.
  3. In the Query window, type the following script:

    delete from MSP_CODE_FIELDS
    where PROJ_ID = 1 and CODE_FIELD_ID= 205521540 and CODE_UID is null
    go


Modification Type:MinorLast Reviewed:9/27/2006
Keywords:kbDatabase kberrmsg kbUser kbprb kbtshoot KB897768 kbAudITPRO