A Windows Server 2003-based computer may repeatedly restart after you uninstall hotfix 842642 (897703)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

A Microsoft Windows Server 2003-based computer may repeatedly restart after you uninstall hotfix 842642.

CAUSE

This problem may occur if the following conditions occur in the order that they are listed:
  1. You install security update 891711 on the computer.
  2. You install hotfix 842642 on the computer.
  3. You uninstall hotfix 842642.
This problem occurs because the Update.exe utility and the Spuninst.exe utility create the same temporary file name for the Winlogon.exe file and the Win32k.sys file.

Note The Update.exe utility and the Spuninst.exe utility are used to install and to remove Windows service packs and some hotfixes.
Note This problem may occur with packages that include a version Update.exe that is earlier than the 6.1.022.4 version.

RESOLUTION

To resolve this problem, either install a service pack or apply a hotfix. After you install the service pack or apply the hotfix, you must modify the registry to enable the fix. For more information, see the "More Information" section.

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 842642.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   06-May-2005  02:24  5.2.3790.326  1,815,552  Win32k.sys
   06-May-2005  22:02  5.2.3790.326    292,352  Winsrv.dll
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size  File name   Platform
   -----------------------------------------------------------------
   05-May-2005  11:05  5.2.3790.326  4,959,744  Win32k.sys  x86
   06-May-2005  07:02  5.2.3790.326    766,464  Winsrv.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Use hotfix 897703 instead of hotfix 842642 to fix a problem. If you already installed hotfix 842642, do not uninstall the hotfix.

If you install Windows Server 2003 Service Pack 1 or hotfix 897703, you must modify the registry to enable the fix. However, if you have already installed the 842642 hotfix and followed the instructions in that article to add the SupportLinkedFontConTextOut registry entry, you do not have to complete the following procedure.

To enable the fix, use one of the following methods:

Method 1. Modify the registry directly

To modify the registry directly, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SupportLinkedFontConTextOut as the entry name, and then press ENTER.
  5. Right-click SupportLinkedFontConTextOut, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Quit Registry Editor.
  8. Restart the computer.

Method 2. Import the registry entry from a file

To import the registry entry from a file, follow these steps:
  1. Start the Notepad program. To do this, click Start, click Run, type notepad.exe in the Open box, and then click OK.
  2. Copy the following data, and then paste the data into Notepad:

    Windows Registry Editor Version 5.00 
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize] 
    "SupportLinkedConTextOut"=dword:00000001

  3. On the File menu, click Save As.
  4. Choose a location to save the file, and then type a descriptive name in the File name box. For example, type GRE_Initialize.reg as the file name.

    Note When you save the file, you must use a .reg extension.
  5. In the Save as type list, click All Files.
  6. In the Encoding list, click Unicode.
  7. Click Save.
  8. Quit Notepad.
  9. Double-click the .reg file that you saved in step 7. This action adds the registry entry.
  10. When you are prompted whether you want to add the information to the registry, click Yes, and then click OK.
  11. Restart the computer.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

891711 MS05-002: Vulnerability in cursor and icon format handling could allow remote code execution

842642 Your Windows Server 2003-based computer crashes and you receive a "Stop 0x00000050" error message


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbWinServ2003SP1fix kbWinServ2003preSP1fix kbBug kbfix KB897703 kbAudITPRO