FIX: When you configure to drain a cluster node in a specified time, the node remains in drain mode after the specified time has elapsed in Application Center 2000 that is running on Windows Server 2003 (897654)



The information in this article applies to:

  • Microsoft Application Center 2000 SP2, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

SYMPTOMS

When you configure to drain a cluster node in a specified time on a computer that is running Microsoft Windows Server 2003, the node remains in drain mode after the specified time has elapsed. For example, when you configure to drain a cluster node in one minute, you expect the node to be offline after one minute. However, the node remains in drain mode. You experience this problem when the following conditions are true:
  • You are running Microsoft Application Center 2000.
  • You configure the Application Center 2000 cluster to use Network Load Balancing (NLB).
Additionally, when you experience this problem, the following event messages are logged in the event log:

Message 1

Event Source: WLBS
Event ID: 44
Time: Time
Description: NLB Cluster IP Address : Connection draining started.

Message 2

Event Source: WLBS
Event ID: 28
Time: Time
Description: NLB Cluster IP Address: Host 32 converged with host(s) 31,32 as part of the cluster.

Message 3

Event Source: WLBS
Event ID: 6
Time: Time AM
Description: NLB Cluster IP Address : Cluster mode stopped. Note You do not experience this problem in Application Center 2000 clusters that are running on Microsoft Windows 2000 Server.

CAUSE

This problem occurs because Windows Server 2003 NLB event sequences have changed. This change may cause the Application Center engine state to be undetermined.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Application Center 2000 Service Pack 2 (SP2)

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Accluster.exe1.0.781.20 343,04003-Jan-2006 06:22x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbHotfixServer kbQFE kbpubtypekc KB897654 kbAudITPRO kbAudDeveloper