You may receive an error message when you try to use an infrared device to transfer files from a Windows XP with Service Pack 2-based computer to a Windows 98-based computer (897649)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional

SYMPTOMS

When you try to use a wireless link that uses an infrared device to transfer files from a Microsoft Windows XP with Service Pack 2 (SP2)-based computer to a Microsoft Windows 98-based computer, you may receive the following error message on the Windows XP-based computer:
Receiving files....
The transfer was cancelled because an error occurred. The system could not find the environment option that was entered.
Note In this scenario, you do not experience this symptom when you transfer files from the Windows 98-based computer to the Windows XP-based computer.

CAUSE

This problem occurs because of a code change in Windows XP SP2 that affects Infrared Data Association protocol (IrDA) devices.

In Windows XP Service Pack 1 (SP1), when you send files to a Windows 98-based computer, the IrDA device first tries to use the Microsoft Windows NT-type connection to transfer files to the Windows 98-based computer. If this method is not successful, the IrDA device then tries to use the Window 98-type connection to transfer files. However, Windows XP SP2 does not try to use the Windows 98-type connection to transfer files after the Windows NT-type connection is not successful. Therefore, you may experience the problem described in the "Symptoms" section.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP SP2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   05-Aug-2005  23:59  5.1.2600.2733  151,552  Irftp.exe
   06-Aug-2005  03:07  5.1.2600.2733   28,160  Irmon.dll
   06-Aug-2005  00:04  5.1.2600.2733   30,720  Arpidfix.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbfix kbbug kbpubtypekc KB897649 kbAudEndUser kbAudITPRO