A file may save with an incorrect file name or with a truncated file name in Microsoft Internet Explorer 6 (897168)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows Server 2003 SP1, when used with:
      • Microsoft Windows Server 2003, Enterprise Edition
      • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows XP Service Pack 2, when used with:
      • Microsoft Windows XP Professional
      • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Service Pack 1, when used with:
      • Microsoft Windows XP Professional
      • Microsoft Windows XP Home Edition

SYMPTOMS

When you try to save a file in Microsoft Internet Explorer 6, one of the following problems may occur:
  • The file may not save with the correct file name.
  • The file may save with a file name that is a truncated version of the file name that appears in the Save As dialog box.
You notice this problem when the following conditions are true:
  • The file uses the "Content-Disposition: Attachment; filename=" header to force a "Save As" operation by Internet Explorer.
  • The file name within the header contains double-byte character sets (DBCS).

CAUSE

This problem occurs because the header length is larger than 256 bytes. Internet Explorer allows for a maximum header length of 256 bytes.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites No prerequisites are required. Restart requirement You must restart the computer after you apply the hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name    Service pack
------------------------------------------------------------------------
12-May-2005  21:05  6.0.3790.330      627,200  Wininet.dll      
13-Jun-2005  19:03  6.0.3790.2463     662,016  Wininet.dll  SP1 

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites To apply this hotfix, you must have Windows XP Service Pack 1(SP1) or Service Pack 2 (SP2) installed on the computer. Restart requirement You must restart the computer after you apply the hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name   Service pack
-----------------------------------------------------------------------
13-May-2005  06:19  6.0.2800.1508     585,216  Wininet.dll SP1     
23-Apr-2005  00:52  6.0.2900.2661     658,432  Wininet.dll SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install the hotfix, there is still a limitation to the length of file names in Internet Explorer. This limitation occurs because of the way that Internet Explorer cache logic operates. After you install this hotfix, a lengthy file name is truncated from the start of the file name. A lengthy file name is no longer replaced with the name of the delivering Web page.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbWinXPsp2fix kbWinXPsp1fix kbWinServ2003preSP1fix kbWinServ2003SP1fix kbBug kbfix kbQFE kbHotfixServer kbpubtypekc KB897168 kbAudEndUser kbAudITPRO