Internet Explorer 6 or a custom printing program stops responding if you print HTML documents on a Windows 2000-based computer (897167)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Professional
    • Microsoft Windows 2000 Advanced Server

SYMPTOMS

If you print multiple HTML documents, Microsoft Internet Explorer or a custom program stops responding. This symptom occurs if the following conditions are true:
  • You are trying to print from either Internet Explorer 6 Service Pack 1 (SP1) or from a custom program that uses Internet Explorer 6 functionality.
  • You are using a Microsoft Windows 2000-based computer.

CAUSE

This problem is caused by a registry key handle leak that is opened by Ddrawex.dll. This leak occurs if the HTML document contains text that was formatted by the following Cascading Style Sheet formatting commands:
  • fliph()
  • flipv()
Every time that you print an HTML document, a new registry key handle is opened by Ddrawex.dll to draw the text that was flipped vertically, horizontally or both for printing. After the print job finishes, Ddrawex.dll does not release the registry key handle. The handle remains in memory as long as Internet Explorer or your custom program is running. If you quit either program, memory is freed and all the registry key handles are cleared from memory.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Apr-2005  22:22  5.0.2195.7039      24,336  Ddrawex.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbhtml kbprint kbBug kbfix kbWin2000preSP5fix KB897167 kbAudEndUser kbAudITPRO