FIX: The virtual catalog is not refreshed if impersonation is being used for the catalog Web service in Commerce Server 2002 Feature Pack 1 (896434)



The information in this article applies to:

  • Microsoft Commerce Server 2002 Feature Pack 1

SYMPTOMS

When you use Microsoft Commerce Server 2002 Feature Pack 1 (FP1) Catalog Manager to refresh a virtual catalog, the virtual catalog is not refreshed. Additionally, you may notice that the Status column in the Catalog Editor for the virtual catalog does not change to Up-to-date. Instead the status of the virtual catalog remains at Requires rebuilding.

CAUSE

This problem may occur if impersonation is being used for the catalog Web service.

Note This hotfix changes the catalog assembly so that the catalog Web service correctly uses the impersonated identity for catalog refreshes.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   --------------------------------------------------------------------
   25-Mar-2005  06:07  4.6.5232.0  393,216  Microsoft.catalogserver.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply the hotfix, you must use the Global Assembly Cache Tool (Gacutil.exe) to manually register the Microsoft .NET Framework assembly in the Global Assembly Cache (GAC). To register the assembly, type the following command at a command prompt, and then press ENTER:

gacutil /i Microsoft.catalogserver.dll /f

Note The Microsoft.catalogserver.dll assembly is typically located in the following folder:

C:\Program Files\Microsoft Commerce Server 2002\FP1\Assemblies

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbBug kbfix kbprb kbQFE kbHotfixServer KB896434 kbAudDeveloper kbAudITPRO