You may receive an error message when you click a hyperlink that references a file on your local computer or on your local network in Internet Explorer 6 (896204)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows Server 2003 SP1

SYMPTOMS

When you click a hyperlink that references a file on your local computer or on your local network, you may receive an error message. This error message varies, depending on the program that you are using.

For example, you may receive the following error message when you click a link to a help topic in the Help and Support Center:
The page cannot be displayed.
Cannot find server or DNS Error

CAUSE

This problem occurs if the URL for the hyperlink includes "%20" instead of a space character.

For example, this problem occurs when you click a link that uses the following HTML code:

<a href = "file://C:/Program%20Files/Test.htm"> This link does not work. </a> 

Note This URL refers to a Test.htm file in your Program Files folder.

This issue occurs because of a change that was made in Microsoft Windows XP Service Pack 2 (SP2) regarding the way that file protocol links are handled.

WORKAROUND

To work around this issue, use one of the following methods.

Method 1: Beginner-to-intermediate users

Contact the manufacturer of your computer or the manufacturer of the program that contains the broken link.

Method 2: Advanced users, IT professionals, software developers, computer manufactures, and OEMs

Replace "%20" with a character space, as in the following example:

<a href = "file://C:/Program Files/Test.htm" > This link does work. </a> 

MORE INFORMATION

Special characters in URLs are encoded with the "%" character and followed by the two-digit number that represents the hexadecimal value of the special character.

For more information about how to encode special characters in URLs, see the RFC 1738 specification on the following Network Working Group Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

For more information about file protocol, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:9/14/2006
Keywords:kbtshoot KB896204 kbAudEndUser