When you use Microsoft Internet Explorer or another program to perform a re-POST operation, only the header data is posted (895954)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows XP Home Edition
    • the operating system: Microsoft Windows XP Professional
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Professional SP2
    • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Professional

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use Microsoft Internet Explorer or another program to perform a re-POST operation, only the header data is posted.

CAUSE

This problem may occur if the XMLHTTP COM Object is used when you post the data or if the InternetWriteFile API is used when you post the data. A network error then forces the data to be posted again.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name 
   ------------------------------------------------------- 
   21-Apr-2005  18:41  6.0.2800.1504  585,216  Wininet.dll

Microsoft Windows XP Service Pack 2

   Date         Time   Version        Size     File name 
   -------------------------------------------------------
   10-Jun-2005  01:42  6.0.2900.2695  658,944  Wininet.dll

Microsoft Windows Server 2003

   Date         Time   Version       Size     File name 
   ------------------------------------------------------
   10-Jun-2005  04:52  6.0.3790.345  627,712  Wininet.dll

How to enable this hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must add the following entry to a registry subkey to enable the hotfix:

Name: *
Type: REG_DWORD
Value: 00000001

To add this registry value, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click one of the following subkeys in the registry. Use the appropriate subkey as specified by your policies for administrating client computers.

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main\FeatureControl

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main\FeatureControl

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl

  3. Click New on the Edit menu, and then click Key.
  4. Type FEATURE_SKIP_POST_RETRY_ON_INTERNETWRITEFILE_KB895954 for the name of the subkey, and then press ENTER.
  5. Click the FEATURE_SKIP_POST_RETRY_ON_INTERNETWRITEFILE_KB895954 subkey.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. Type * for the DWORD name, and then press ENTER.
  8. Right-click *, and then click Modify.
  9. In the Value data box, type 00000001, and then click OK.
  10. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbfix kbbug kbpubtypekc KB895954 kbAudITPRO