Active Directory Users and Computers may stop responding when you use Active Directory Users and Computers on a server that is not running Exchange Server 2003 to change a user's proxy address (895668)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition


Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you use Active Directory Users and Computers on a server that is not running Microsoft Exchange Server 2003 to change a user's proxy address, Active Directory Users and Computers may stop responding.

CAUSE

This problem occurs if the first Exchange server on the Lightweight Directory Access Protocol (LDAP) query list is in a remote site. Active Directory Users and Computers uses the first Exchange server on the LDAP query list to change the user's proxy address. If the first server on the LDAP query list is in a remote site, Active Directory Users and Computers may stop responding.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this software update requires Microsoft Exchange Server 2003 Service Pack 1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time   Version            Size    File name
   -------------------------------------------------------------- 
   06-May-2005  02:04  6.5.7233.14    14,628,864  Maildsmx.dll     
After you install this hotfix, you must configure a new registry entry to apply this hotfix. To configure the new registry entry, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeMGMT\Parameters

  3. On the Edit menu, point to New, and then click String Value.
  4. Name the new registry entry "Preferred SA Server".
  5. Right-click Preferred SA Server, and then click Modify.
  6. In the Value data box, type server_name, and then click OK.

    In this value, server_name is the name of the Exchange server that you want Active Directory User and Computers to use.
  7. Close Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, when Active Directory Users and Computers tries to find an Exchange server, it checks whether the Exchange server that you specified in the Preferred SA Server registry entry is available. If this Exchange server is not available, Active Directory Users and Computers uses an LDAP query to obtain a server list. Active Directory Users and Computers selects a server from this list.

Notes
  • This hotfix will have no effect if you install this hotfix on an Exchange server.
  • The hotfix and registry change should be made on the member server or the remote client computer that is running the Microsoft Exchange version of Active Directory Users and Computers (Microsoft Exchange Management Tools).

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbQFE KBHotfixServer kbexchSETUP kbfix kbBug kbpubtypekc KB895668 kbAudITPRO